Kiosk Industry Info

IE Zero Day Vulnerability

Monday, May 5, 2014

If you are running Windows Operating Systems on any of your kiosks, you will want to take a moment to read this.  Over the last week, a vulnerability has been identified and exposed in Internet Explorer.  A fix to this vulnerability was released on Thursday evening (May 1).  Because this has occurred so close to the end of life for Windows XP, they have also issued an update for XP.  As such, you will want to make sure that you update your Windows devices in order to protect from attacks or security issues. 

Here’s How to Update IE

Click the “Check for Updates” button on the Windows Update portion of your Control Panel to update your system. 

Windows XP Users

If you are still using XP, consider how this would have impacted your business if Microsoft had maintained their position of “no support for XP systems”.  You would have had an immediate need to upgrade to a new operating system because your old one would have a major security flaw.  Microsoft may or may not issue any future fixes for XP and working now to update your OS is the safest way to be sure that you will be able to patch any future vulnerabilities.   Read more about how to upgrade the operating system and maintain your KioWare kiosk license

Of course, this does not impact Android devices.  KioWare for Android users can disregard.


Archive:
Try a free, fully-functioning demo of Kioware Kiosk Software before purchasing. SIGN UP