Kiosk Industry Info

News About Internet Explorer End of Support

Wednesday, December 2, 2015

End of Support for Internet Explorer®: Which Version? 

If you are currently operating kiosks running the Microsoft® Windows® OS, you may be impacted by Microsoft's recent announcement with regard to end of support for Internet Explorer.  Beginning on Janury 12, 2016, only the most current version of Internet Explorer for your operating system (usually IE 11) will receive technical support and security updates.  If you are running IE 6, IE 7, IE 8, IE 9 or IE10, your browser (and therefore kiosk) may be at risk of security vulnerabilities beginning on January 12.  

You should, therefore, update to Internet Explorer 11, particularly if your kiosk OS is Windows 7 or Windows 8.1.  View the support chart here if you want to view all versions of Windows and what version of IE is available for your operating system as it varies greatly.  One example of a non IE 11 supported browser, for instance, is Windows Embedded for Point of Service, which will continue to support Internet Explorer 7.  Support for that version of Internet Explorer will continue for the lifecycle of the operating system.

What does Microsoft's Internet Explorer End of Support Announcement  mean for your kiosks?  

If you are running a version of KioWare Classic for Windows released before 7.1.0, you will need to update support, and your kiosks, to a more recent version (7.1.0-7.4.0).  This is because KioWare Classic for Windows began supporting IE 11 with version 7.1.0.  If you instead decide to switch to a Chrome browser engine, you have the option to transition your licenses to the new KioWare for Windows, version 8.0 or higher.  Either of these solutions are valid as long as your licenses are up to date with support.

If you choose to continue running older (and therefore, unsupported) versions of Internet Explorer past the January 12, 2016 end of support date, your kiosks will be at risk and vulnerable to security breaches and gaps.  

Here is a "how to" update your Windows kiosks and your KioWare Licenses posted on Spiceworks when Windows XP was on the way out. IF you are not sure if you should switch to the new KioWare for Windows (built using a Chromium Browser Engine) or stay with KioWare Classic for Windows (running Internet Explorer), you will want to think about your application or website and determine if it is designed for Chrome and Internet Explorer both, or if it is designed for Internet Explorer with little testing/support for rendering in the Chrome browser.  Feel free to contact KioWare for more information or download both KioWare Classic (7.4.0) and KioWare for Windows (8.2) and test them with your application or website.  

_________________________________________________________

 

KioWare Tip: Import your XML configuration settings file to KioWare Classic for Windows version 7.4.0, then use the KioWare for Windows Importer tool to convert your settings from KioWare Classic to the new KioWare.  While some more advanced configuration settings will not transfer, you will be able to quickly see how both programs work without having to configure the software from scratch.  This will also allow you to test your application/browser with both Internet Explorer and Chrome browser engines.  You will also want to make sure that you have updated your IE browser to the most recent release supported by your OS.

_________________________________________________________

 

 


Archive:
Try a free, fully-functioning demo of Kioware Kiosk Software before purchasing. SIGN UP